Vous n'avez pas encore de notification

Page d'accueil

Options d'affichage

Abonné

Actualités

Abonné

Des thèmes sont disponibles :

Thème de baseThème de baseThème sombreThème sombreThème yinyang clairThème yinyang clairThème yinyang sombreThème yinyang sombreThème orange mécanique clairThème orange mécanique clairThème orange mécanique sombreThème orange mécanique sombreThème rose clairThème rose clairThème rose sombreThème rose sombre

Vous n'êtes pas encore INpactien ?

Inscrivez-vous !
Une extension pour connaître la version TLS des sites que vous visitez

Il existe de nombreux services permettant de connaître le niveau du chiffrement proposé pour un domaine, du test de Qualys à celui mis en place par Aeris.

Mais un développeur a décidé de proposer l'affichage de telles informations directement au sein d'une extension. Vous pouvez ainsi directement voir la version de TLS utilisée, puis quelques détails dans une pop-up après un clic.

IndicateTLS n'est proposée que pour Firefox, utilisant l'API webRequest.SecurityInfo. Open source, son code est diffusé sous licence MPL 2.0.

8 commentaires
Avatar de ndjpoye Abonné
Avatar de ndjpoyendjpoye- 25/05/20 à 08:39:25

Ha, ma jeunesse :phibee:

Sinon, je ne sais pas si c'est d'époque mais, les quelques fichiers que j'ai regardés sont pas mal commenté 

Avatar de Gawked Abonné
Avatar de GawkedGawked- 25/05/20 à 08:48:24

Ou sinon il suffit de cliquer sur le petit cadenas dans la barre d’adresse, puis sur Plus d’Information et Firefox nous donne la version de TLS, le nombre de bits de la clé, le type de chiffrement etc

Avatar de Sans intérêt Abonné
Avatar de Sans intérêtSans intérêt- 25/05/20 à 10:41:35

Certes. Néanmoins, comme le suggèrent les captures d'écran de l'extension, le numéro de version est intégré dans la barre d'adresse, ne réclamant donc aucun clic. Pour des informations complémentaires, il clic semble plus complet que la fonction native du navigateur.

Avatar de Ced-le-pingouin Abonné
Avatar de Ced-le-pingouinCed-le-pingouin- 25/05/20 à 11:25:10

Est-ce que tu ne répondais pas plutôt à la brève sur GW-BASIC ;-) .

Avatar de ndjpoye Abonné
Avatar de ndjpoyendjpoye- 25/05/20 à 11:28:41

Ced-le-pingouin a écrit :

Est-ce que tu ne répondais pas plutôt à la brève sur GW-BASIC ;-) .

:oops: J'ai glissé chef.

Oui :transpi:

Avatar de grsbdl INpactien
Avatar de grsbdlgrsbdl- 25/05/20 à 12:57:01

Pro-tip : si l'extension ne marche pas (affiche un "?"), pensez à Ctrl+F5, ou videz carrément votre cache.
Certains sites ont encore du mal (ex Gmail à chaque rafraichissement) mais grosso-modo ça passe.

Avatar de CryoGen Abonné
Avatar de CryoGenCryoGen- 25/05/20 à 14:03:28

Han NXI n'est pas totalement en 1.3 rohhh :francais:

Avatar de CryoGen Abonné
Avatar de CryoGenCryoGen- 25/05/20 à 14:06:01

Oui mais il se limite à la connexion initiale apparemment.
L'extension m'indique qu'une partie des hôtes appelés par le site ensuite, ne sont pas en TLS1.3, mais 1.2 (cdn6.nextinpact.com par exemple).

Il n'est plus possible de commenter cette actualité.