Vous n'avez pas encore de notification

Page d'accueil

Options d'affichage

Abonné

Actualités

Abonné

Des thèmes sont disponibles :

Thème de baseThème de baseThème sombreThème sombreThème yinyang clairThème yinyang clairThème yinyang sombreThème yinyang sombreThème orange mécanique clairThème orange mécanique clairThème orange mécanique sombreThème orange mécanique sombreThème rose clairThème rose clairThème rose sombreThème rose sombre

Vous n'êtes pas encore INpactien ?

Inscrivez-vous !
Un défilement plus fluide des pages dans Firefox Quantum

La prochaine version majeure du navigateur embarquera l’APZ, pour « Asynchronous panning and zooming ».

Ce vieux projet de Mozilla permet un défilement plus doux des pages. Une opération confiée jusqu’ici au thread principal, qui calcule également les opérations JavaScript. Conséquence, en cas de calculs intenses, le défilement se fait par saccades, donnant le sentiment d’un navigateur peu performant.

L’APZ est désormais présent dans Firefox Quantum et profite de l’architecture multiprocessus pour voir ses opérations déportées vers un thread spécifique. De plus, outre la souris et trackpads, tous les évènements de type input sont pris en charge, y compris les via les écrans tactiles ou la navigation au clavier.

Mozilla note cependant que l’APZ aura dans certains cas quelques inconvénients pour les développeurs, l’éditeur s’expliquant en détails dans son billet d’annonce. Cependant, il estime que le jeu en vaut la chandelle côté utilisateur.

3 commentaires
Avatar de Zone démilitarisée Abonné
Avatar de Zone démilitariséeZone démilitarisée- 07/11/17 à 21:35:02

Cela pourrait présenter le risque d'un défilement vers du contenu de page non encore calculé.

Avatar de Fennec72 Abonné
Avatar de Fennec72Fennec72- 08/11/17 à 08:24:44

Un grand nombre de modules complémentaires historiques de Firefox ne sont pas encore compatibles avec Firefox 57 (quantum).
Exemples : Open with ou webdeveloper

Avatar de loki2 INpactien
Avatar de loki2loki2- 12/11/17 à 20:37:06

@fennec72

wep, comme module obsolètes pour moi :  GreasemMonkey, Context search, TextArea Cache, Status-4-evar, Better privacy

Il n'est plus possible de commenter cette actualité.