Vous n'avez pas encore de notification

Page d'accueil

Options d'affichage

Abonné

Actualités

Abonné

Des thèmes sont disponibles :

Thème de baseThème de baseThème sombreThème sombreThème yinyang clairThème yinyang clairThème yinyang sombreThème yinyang sombreThème orange mécanique clairThème orange mécanique clairThème orange mécanique sombreThème orange mécanique sombreThème rose clairThème rose clairThème rose sombreThème rose sombre

Vous n'êtes pas encore INpactien ?

Inscrivez-vous !
LastPass : une première Beta pour Firefox 57 et ses WebExtensions

Certains attendaient cette annonce comme le messie, c'est désormais une réalité : LastPass est disponible sous forme d'une WebExtension et donc compatible avec Firefox 57.

Pour rappel, cette nouvelle version du navigateur doit sortir le mois prochain et coupera totalement les ponts avec les extensions sous leur forme classique. Les développeurs ont dû s'adapter, et certains le font plus tardivement que d'autres.

L'équipe de LastPass précise d'ailleurs que cette première mouture n'est qu'une bêta et que certaines fonctionnalités sont pour le moment inactives puisqu'il manque le lien entre l'application classique et l'extension.

8 commentaires
Avatar de wanou2 Abonné
Avatar de wanou2wanou2- 16/10/17 à 09:05:50

youhouuuuu :youhou:

Avatar de espritordu Abonné
Avatar de espritorduespritordu- 16/10/17 à 09:30:47

Y'a pu qu'à le passer en Français et on aura peut-être enfin un gestionnaire de mot de passe à proposer à Jean-Michel TPE pour qu'il arrête de mettre "titigrominet29" en mot de passe admin de son back-office.

Avatar de clementbd INpactien
Avatar de clementbdclementbd- 16/10/17 à 10:06:07

:yes:

Avatar de Bejarid INpactien
Avatar de BejaridBejarid- 16/10/17 à 11:06:57

La majorité des mes extensions ont toujours pas de version WE, pour certaines c'est même annoncé qu'elles n'en auront pas, et il n'y a pas d'alternatives aussi puissantes pour l'instant (manipulation d'image, mouvement de souris, gestion du drag & drop, des onglets, des favoris, ...).

J'ai l'impression que Mozilla s'est lancé dans cette aventure en mode "YOLO, on verra ce qu'il se passe de toute façon c'est pas grave c'est pas comme si notre navigateur était aussi utilisable qu'internet explorer sans elles LOL". Ça fait vraiment amateur et je-m'en-foutiste...

Avatar de Neptunelight Abonné
Avatar de NeptunelightNeptunelight- 16/10/17 à 11:13:31

:incline:

Avatar de wanou2 Abonné
Avatar de wanou2wanou2- 16/10/17 à 16:28:54

D'un autre coté, il y a certains moment il faut des ruptures. Le système d'extension à près de 15 ans, il était peut être temps de revoir un peu la chose. Il ne faut pas oublier que ça fait 2 ans que Mozilla a prévenu de la fin du support de xul.

Avatar de Bejarid INpactien
Avatar de BejaridBejarid- 17/10/17 à 01:03:12

Le SDK, et surtout le navigateur à peu près stable qui permet de le tester, sont dispo depuis quand ? Quelques semaines. Y qu'a voir les problèmes qu'a eu le dev de uBlock Origin. Et pourtant c'est un modèle. Il a été obligé de faire ça dans un temps très cours, tout en se battant avec les bugs du SDK, sans parler du mode hybride, indispensable pour pas perdre les configs, qui n'était même pas prête le jour où l'extension se faisait tagguer "d'obsolète".

Non, franchement, Mozilla a gérer de façon immonde et s'est mit bêtement à dos pas mal de dev juste parce qu'ils ont voulu tenir des délais impossibles vu les retards accumulés de leur coté. La réactivité de l'équipe FireFox a permis d'éviter la catastrophe, mais la scène des extensions de FF en ressort très affaibli.

Incompréhensible !

Avatar de Ludestru INpactien
Avatar de LudestruLudestru- 18/10/17 à 00:44:24

Le soucis, c'est que pour l'instant, il a perdu plusieurs fonctionnalités et est tout de même encore pas mal bugué même pour certaines fonctions qui me semblent basiques. (pour l'instant, avec la dernière mise à jour de la bêta).

Il n'est plus possible de commenter cette actualité.