CyanogenMod : pas d'Android 4.0 (ICS) pour les HTC Desire, Nexus One, etc.

cyanogenMod

 

C'est via un billet sur Google+ que les développeurs de CyanogenMod ont annoncé que les smartphones exploitant un SoC QSD8x50, MSM7x25, MSM7x27 ou MSM7x27T resteront bloqués sur Gingerbread aka Android 2.3 (CM 7). Pour rappel, ces derniers sont intégrés au sein de nombreux mobiles tels que le Nexus One de Google, les Desire et Legend d'HTC ainsi que les Huawei U8150 et U8220. La liste complète des modèles concernés est disponible ici.

 

Ils précisent qu'il ne s'agit pas d'une barrière absolument infranchissable, certaines ROM alternatives étant d'ailleurs proposées, mais plutôt d'une limite au niveau du temps et des efforts nécessaires au développement de ces versions. Un choix qui est ainsi résumé : « Est-ce que ces terminaux ont la possibilité de faire tourner ICS ou Jelly Bean ? Oui. Estimons-nous que l'expérience vaut la peine de faire tout cela ? Non ».

 

android jelly bean  

 

En effet, pour réussir à porter la mouture 9 de CyanogenMod (basée sur Android 4.0) il aurait été nécessaire de faire de trop gros compromis sur les fonctionnalités, tout en nécessitant un énorme travail du côté du partitionnement et des bibliothèques d'applications (notamment pour l'encodage et le décodage vidéo).

 

De plus, les équipes de développeurs pointent du doigt un autre problème : la non-compatibilité de leur firmware avec l'Android Compatibility Test Suite (CTS). Il s'agit d'une batterie de tests utilisés par les fabricants afin de valider leur ROM maison et d'être sûrs qu'elle respecte les standards définis par Android. Le problème étant que cela pourrait entrainer des conséquences relativement importantes pour CyanogenMod avec, par exemple, l'impossibilité d'accéder au Play Store de Google. Ainsi, ce choix n'est pas totalement définitif : « si, à l'avenir, une solution pour passer le CTS est trouvée, nous réviserons notre position sur le sujet ».

 

Pour finir, sachez une nouvelle fonctionnalité est actuellement en cours d'évolution : les comptes multi-utilisateurs. Celle-ci est d'ores et déjà disponible sur certaines moutures de CM 10 (basée sur Jelly Bean) et devrait donc se généraliser au cours des prochaines semaines :

 

cyanognemod 10 multi utilisateur

Vous n'avez pas encore de notification

Page d'accueil
Options d'affichage
Abonné
Actualités
Abonné
Des thèmes sont disponibles :
Thème de baseThème de baseThème sombreThème sombreThème yinyang clairThème yinyang clairThème yinyang sombreThème yinyang sombreThème orange mécanique clairThème orange mécanique clairThème orange mécanique sombreThème orange mécanique sombreThème rose clairThème rose clairThème rose sombreThème rose sombre

Vous n'êtes pas encore INpactien ?

Inscrivez-vous !